在Ubuntu 11.04 裏看PPStream


這篇轉貼自http://www.wmfield.idv.tw/802

十分簡單的方法:

1. 開終端機,輸入:

sudo apt-get install libqt4-core libqt4-dbus libqt4-gui 
sudo apt-get install libqt4-network libqt4-webkit 
sudo apt-get install libqt4-xml libfuse2 mplayer

把會用到的套件裝齊。

2. 必要套件安裝完成後,再輸入:

sudo apt-add-repository ppa:cnav/ppa

加入神人的套件庫。

3. 開 synaptic 套件管理程式,按「設定」→「套件庫」→「其他軟體」。找:

http://ppa.launchpad.net/cnav/ppa/ubuntu maverick main
http://ppa.launchpad.net/cnav/ppa/ubuntu maverick main(原始碼)

按底下「編輯」編輯這兩段,把發行版本改成「natty」,也就是變成這樣:

http://ppa.launchpad.net/cnav/ppa/ubuntu natty main
http://ppa.launchpad.net/cnav/ppa/ubuntu natty main(原始碼)

因為沒有給maverick用的套件庫,所以直接使用natty的。

4. 更新套件庫,開終端機輸入:

sudo apt-get update

或是直接在 synaptic 裡按「重新載入」。

5. 安裝 PPStream,開終端機輸入:

sudo apt-get install ppstream

6. 建議重新啟動電腦後再啟動 PPStream,第一次啟動會比較久。
PPStream會在「應用程式」→「網際網路」→「PPStream」,程式圖示與 Windows 版本相同。

7. 啟動後,需要再調整一下聲音輸出介面,PPStream才能出聲。
按上面功能列「工具」→「選項」,找「選擇音頻設備」,從「設置當前音頻設備」的下拉選單中把「oss」改為「alsa」。

測試後成功:

2 thoughts on “在Ubuntu 11.04 裏看PPStream

  1. 如果你使用Ubuntu 11.04 32-bit的話,可以直接用官方的那個版本:
    http://download.ppstream.com/ppstream_1.0.0-1_i386.deb

    如果你使用64-bit的版本,問題就可能出於那個安裝包Compile出錯:
    … with ppstream:i386 1.0.0 (Multi-Arch: no)…

    –>解決:http://www.dotblogs.com.tw/bowwowxx/archive/2010/12/31/20502.aspx

    不過本人之前也適用Ubuntu 11.04 64-bit的,就沒有發生問題,可能別的方法比較適合~

  2. 我用 Ubuntu 11.04, apt-get install ppstream 后,遇到如下的问题

    dpkg: error processing /var/cache/apt/archives/ppstream_1.0.0+1-1_amd64.deb (–unpack):
    ppstream: 1.0.0+1-1 (Multi-Arch: no) is not co-installable with ppstream:i386 1.0.0 (Multi-Arch: no) which is currently installed
    Errors were encountered while processing:
    /var/cache/apt/archives/ppstream_1.0.0+1-1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    请问如何解决呢?谢谢!

塗牆

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com Logo

您的留言將使用 WordPress.com 帳號。 登出 / 變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 / 變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 / 變更 )

Google+ photo

您的留言將使用 Google+ 帳號。 登出 / 變更 )

連結到 %s